查看: 77393|回复: 21

[T系列] T420加装SSD,血泪史从此开始

[复制链接]

该用户从未签到

发表于 2016-4-26 09:53 | 显示全部楼层 |阅读模式
                     本人的老笔记本T420,闲来无事,加了个SSD,型号是建兴的SMS-128L9M,网上评论还不错,是MSATA接口的。 IMG_0242.jpg IMG_0239.jpg                       刚收到就装上了,系统自然也重新安装了一遍。一切都非常的顺利。开机速度也还行,原来要1分钟左右,现在20S左右,开机后的各种测试,毕竟那个MSATA接口是SATA2.0的, IMG_0270a.JPG
觉得可以了,感叹,还可以再坚持几年了。
              开始安装软件了,我的软件包都是在机械盘里的。先装了办公软件,一个字,快,能后装一些我要用的一些设计软件,大概有3G左右。前面都是安装时要设置安装目录什么的,因为我安装了很多次,可以说很熟练,突然电脑不动了,整个安装的画面定住了,我想是不是我点得太快了,电脑跟不上,等等它吧,等了两分钟,还是不动。他娘的,难道死机了,心里想着,能后试着点别的地方,都正常,就是安装软件有问题,可能真是自已点太快了,导致安装程序跟不上,无响应了,按三个组合键,打开任务管理器,将软件安装程序关掉。大不了重新再来。却怎么关也关不掉,电脑别的功能都能点,包括上网什么的,都正常。只是这个安装程序关不掉。应该不能算死机了。没事,重启吧。能后点关机,重启,等了半天,也没见电脑有反应,晕了,难道是系统的问题。强制关机,长按电源键5秒。顺利关机。


            重启后,又开始安装软件,这次别点那么快了,电脑跟不上,顺利装上。得出一个结论,我的大脑比电脑反应要快。难道是SSD的问题?还是系统没装好?先不管它了,先用了再说。开软件比原来要快了,只是凭感觉。还算值得吧。只要比原来快就行,要求不高。
           玩了一会,洗澡去了,洗澡回来,电脑已睡眠,按下FN键,电脑已恢复。去看看还有哪些软件还要装,打开我的电脑,发现原来有六个盘的,现在只剩下两个了,这两个是SSD的,我分了两个盘,一个是系统,一个是软件。原来的HDD有四个盘,都不见了。晕,查看我的设备,没有看到有HDD硬盘。心想,难道刚用SSD,HDD就坏了,这也太巧了。不多想了,重启试下。结果更让我确信了这一点。看图 IMG_0335.jpg
进入BIOS,也没有HDD了。关机,静静的坐着,我的资料,我的照片,完了,完了。
         再次开机,看HDD能不能有机会再活一次,只要一次就行,老天对我还行,我的电脑又出现了六个盘,真是高兴啊,不想别的,备份资料。我有一个移动硬盘500G的。资料备份完后,长嘘一口气。啥也不怕了。连续开机,关机几次,都正常。我想HDD也没那么容易坏吧。用了几年也没出过问题。
         开始找度娘,到底啥原因呢。可爱的网络,让我找到了跟我一样有同种问题的。有一个专业术语,叫掉盘。按网上提供的方法,什么擦金手指啦。调高性能啦,反复试了N次,总会在不经意的时候掉盘,时有,明无,而且有时读取HDD的资料会慢。终于明白了装软件时卡死是什么原因了。网上还有很多说是硬盘问题,对HDD也是反复的用硬盘检测软件测试,并没有任何问题。奇了怪了。
         我手上的移动硬盘,将其拆出,里面是一个2.5希捷7MM厚5400转的硬盘。将原来笔记本的硬盘拆出,是东芝9MM厚的,7200转的。将希捷的硬盘装上去,经过两天 IMG_0355.jpg
测试,没有出现掉盘,掉速现象。难道真是硬盘问题?将拆出来的东芝硬盘挂到台式机上,用了两天,也没出现有掉盘。更奇怪了,难道是兼容问题?也无从得知了。网上有网友说的电源带不动,特别留意了一下两个硬盘的电流参数。东芝的是5V 1.1A,希捷的是5V 0.55A,差了一倍。难道真是电源带不动?本人有一点点强迫证,凡事都想弄个明白。希望有大神能够解答一下。
IMG_0351.jpg
IMG_0273a.JPG
IMG_0337a.JPG
  • TA的每日心情
    开心
    2020-3-28 12:00
  • 发表于 2016-4-26 10:35 | 显示全部楼层
    本帖最后由 xiaohongxi 于 2016-4-26 12:48 编辑

    这是很明显的SSD硬盘使用了IDE驱动使用版本不对出现的卡顿现象。
    1、SSD分区必须4K对齐(建议只分一个区);
    2、T420 的硬盘驱动最好使用系统自带的,如果要使用联想的OEM驱动,只能使用11.2.0.1006版本,不要使用12.0以上版本。如果使用了12.0以上版本请卸载或回滚到系统自带的IDE驱动问题迎刃而解。
    3、HDD如果支持4K对齐的,分区时也要4K对齐。我也是T420,使用浦科特128G SSD mSATA做系统盘,开始也遇到与楼主一样的问题,寻觅许久才找到解决方案。
  • TA的每日心情
    可爱
    2016-11-30 17:26
  • 发表于 2016-4-26 11:24 | 显示全部楼层
    都两个硬盘了,还分区做什么,SSD用来装系统,软件的安装路径就默认即可,机械硬盘用来装文件,也不用分区,分文件夹就行,打开电脑清清爽爽两个盘符多好。

    该用户从未签到

     楼主| 发表于 2016-4-26 19:04 | 显示全部楼层
    xiaohongxi 发表于 2016-4-26 10:35
    这是很明显的SSD硬盘使用了IDE驱动使用版本不对出现的卡顿现象。
    1、SSD分区必须4K对齐(建议只分一个区) ...

    非常感谢你的回答,但我的情况可能跟你不一样,
    1,系统装的是WIN7 64位原版的,增加了THINKPAD的OEM文件,基本算原版,会自动激活。
    2,SSD用的是WIN7的安装盘分的区,已经是4K对齐的。HDD也是4K对齐的。
    3,刚刚查了一下两个磁盘的驱动,都是系统自带的,见附图。4,我在系统不变的情况下,只是更换了另一块HDD硬盘,这块硬盘就没有掉盘的现象,我再将原来硬盘换过来,还是会掉盘。
    5,还请大神再帮看看。到底是什么原因呢。
    无标题2.jpg 无标题1.jpg

    该用户从未签到

     楼主| 发表于 2016-4-26 19:05 | 显示全部楼层
    本帖最后由 ukqihpgy 于 2016-4-26 19:13 编辑
    yinxvn 发表于 2016-4-26 11:24
    都两个硬盘了,还分区做什么,SSD用来装系统,软件的安装路径就默认即可,机械硬盘用来装文件,也不用分区, ...

    个人习惯吧,我喜欢系统装C盘,软件装D盘,这个做个系统备份不会那么大。而且我所用的软件有些会建很多零件库,如果装在C盘的话,恢复系统的话,那些后面建的就没有了。仓库盘也是分类的,最后一个盘基本是只存,是个数据盘,系统备份,重要文件备份。个人习惯很难改的。

    该用户从未签到

     楼主| 发表于 2016-4-26 19:16 | 显示全部楼层
    顶起来,让更多大神能看到,并帮帮小弟
  • TA的每日心情
    开心
    2020-3-28 12:00
  • 发表于 2016-4-26 20:21 | 显示全部楼层
    本帖最后由 xiaohongxi 于 2016-4-26 20:27 编辑
    ukqihpgy 发表于 2016-4-26 19:04
    非常感谢你的回答,但我的情况可能跟你不一样,
    1,系统装的是WIN7 64位原版的,增加了THINKPAD的OEM文件 ...

    1、下载磁盘工具DiskGenius、HDTune检查一下HDD(绝不会因为硬盘1A的工作电流就造成卡顿);
    2、SSD容量有128GB了,系统和常用的软件例如Office、图形编辑软件等最好放在系统盘才能够体现出飞速的快感,只是将软件所产生的文件放到HDD仓库;
    3、如果您没有安装联想OEM硬盘驱动,可以安装11.2.0.1006版试试;
    4、T420的主板驱动和其它驱动、电源管理芯片驱动是否正确安装?HDD接口金手指是否有脏污?还是买一瓶WD-40滴一滴在上面清洗一下,保证接触良好。

    该用户从未签到

     楼主| 发表于 2016-4-26 22:11 | 显示全部楼层
    xiaohongxi 发表于 2016-4-26 20:21
    1、下载磁盘工具DiskGenius、HDTune检查一下HDD(绝不会因为硬盘1A的工作电流就造成卡顿);
    2、SSD容量 ...

    硬盘拆了装,装了拆,不下十次了。也用磁盘工具测试了N次,没有查到问题。就只有你说的那个OEM硬盘驱动没有装,现在在用希捷的HDD,没有问题,因手头上有点事要忙,下次再换上东芝的HDD来试。还是谢谢你。

    该用户从未签到

    发表于 2016-4-27 11:55 | 显示全部楼层
    我就看看,然后不做声,在然后就走掉了
    thinkpadt005 该用户已被删除
    发表于 2016-5-2 01:08 | 显示全部楼层
    提示: 作者被禁止或删除 内容自动屏蔽

    该用户从未签到

    发表于 2016-5-5 09:23 | 显示全部楼层
    SSD掉盘?~

    该用户从未签到

    发表于 2016-8-4 12:18 | 显示全部楼层
    SSD 迷你固态  不要分区安装系统应该是没问题的

    该用户从未签到

    发表于 2016-8-8 21:14 | 显示全部楼层
    是不是msata质量不行,我买的比你贵的品牌,都OK。

    该用户从未签到

    发表于 2016-8-18 13:48 | 显示全部楼层
    你看看你的SSD驱动是不是微软的,换成INTEL的
  • TA的每日心情
    可爱
    2018-4-20 22:53
  • 发表于 2016-8-20 20:34 | 显示全部楼层
    我也是升级了X220,原来的机械硬盘换成桑心的SSD,用着很好,开机快的5秒,慢的也就12秒。但是添加了第二块SSD--MSATA以后就各种不顺。各种小麻烦。我也怀疑是msata质量不行(朗科120G的msata)。有时候开机还会加装朗科的驱动,速度也慢了很多。现在还在考虑要不要废了msata,只用三星的。

    该用户从未签到

    发表于 2016-8-21 22:14 | 显示全部楼层
    你好,我的笔记本也想加,我不会,请教你。

    该用户从未签到

    发表于 2016-8-26 11:29 | 显示全部楼层
    提供个思路供参考吧,我觉得要找出掉盘的问题根源,可以考虑在运行时观察系统运行日志,看看在加载了操作系统后,什么时候出现的掉盘导致的死机啊什么的。然后反查一下系统日志,逐个排除法,否则在操作系统加载前,出现不识别盘的现象,你只能找bois的问题所在了,因为没有OS级的日志记录,你在bois接管办卡设备阶段,没有日志记录辅佐,什么判断也只是猜测,只能以替换法来辅助判断啊,但是你看bois又没有日志啊,总不能让你把bois启动阶段的内存和cpu状态dump出来吧,那个翻出来没有几个人能读得懂啊。

    所以啊,不要纠结了,大致分类一下啊问题方向即可,我任务,不是电流大小的原因,那个电流大小和硬盘马达功耗相关。
  • TA的每日心情
    闭嘴
    2019-2-15 22:53
  • 发表于 2016-9-10 08:14 | 显示全部楼层
    路过帮顶。

    该用户从未签到

    发表于 2016-9-13 13:06 | 显示全部楼层
    又学习了不少东西,谢谢。
  • TA的每日心情
    慵懒
    2017-9-21 09:10
  • 发表于 2016-9-28 21:52 | 显示全部楼层
    学习了
    您需要登录后才可以回帖 登录 | 注册

    本版积分规则

    意见反馈|Archiver|手机版|小黑屋|本友会 ( 北京市公安局海淀分局网监中心备案编号:11010802020118  

    GMT+8, 2020-3-29 12:22 , Processed in 0.067507 second(s), 14 queries , Memcache On.

    Powered by Discuz! X3.2

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表